Why not working?

Dec 1, 2011 at 8:04 AM

HI!

I add SPSolution and activated the feature in Central Admin, but I not see in SharePoint Designer when I create new workflow.

I use Hungarian SharePoint 2010.

Please help!

Thanks,

Niki

Coordinator
Dec 1, 2011 at 4:06 PM
Edited Dec 1, 2011 at 4:07 PM

Niki,

You will need to download the source and make a few changes to match your localization settings.  The solution has two projects, you should only need to modify the project named "CustomSharePointActivitiesProject".  The only modification i think you need to make is to add or change the sharepoint mapped folder (the folder with the green dot on it named "Workflow" to be the one that matches your localization.  This current folder is mapped to 1033 for english, obviously hungarian will be different.  You may also want to update the actions file in your localized folder (CustomWorkflow.ACTIONS) to be in your native language unless all you users can read and understand english.  Then just deploy the project and you should be good to go.

-Rob

EDIT:  Also, if you do create a hungarian version of the actions file, feel free to share it back so that i can put one up here for others to use.

Dec 2, 2011 at 8:45 AM

Thank you!

It's working, any I think it is a very good solution.

I have a question: I try Send email extended (to my gmail address) but not send e-mail, I get this error message: "System.Net.Mail.SmtpFailedRecipientException: Nem érhető el a postafiók. A kiszolgáló válasza a következő volt: 5.7.1 Unable to relay a következő helyen: System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, Stri"

I needed to set my companie SMTP server?

I want, if I create list item, then send e-mail to other companies e-mail address.

Thanks,

Niki

Coordinator
Dec 2, 2011 at 8:27 PM

Niki,

have you already setup mail for your sharepoint instance?  Does the out of the box workflow email activity work?  I would suggest you start there first so that you can confirm is this solution is to blame or if you simply havent setup/configured mail for your sharepoint farm yet. 

Here are the instructions from microsoft for setting up outgoing mail for SharePoint 2010. (http://technet.microsoft.com/en-us/library/cc263462.aspx)

<!---->

To configure outgoing e-mail for a farm by using Central Administration

  1. Verify that you have the following administrative credentials: You must be a member of the Farm Administrators group on the computer that is running the SharePoint Central Administration Web site.

  2. In Central Administration, click System Settings.

  3. On the System Settings page, in the E-Mail and Text Messages (SMS) section, click Configure outgoing e-mail settings.

  4. On the Outgoing E-Mail Settings page, in the Mail Settings section, type the SMTP server name for outgoing e-mail (for example, mail.example.com) in the Outbound SMTP server box.

  5. In the From address box, type the e-mail address as you want it to be displayed to e-mail recipients.

  6. In the Reply-to address box, type the e-mail address to which you want e-mail recipients to reply.

  7. In the Character set list, select the character set that is appropriate for your language.

  8. Click OK

Dec 5, 2011 at 7:41 AM

I configure the outgoing e-mail for a farm ( I have more workflow, who working send e-mail to my colleague's), but If I try to other (gmail) address send e-mail, not working.

My goal is, If I create new item in List (ex.: IT support) and I add e-mail address column who I write my client e-mail address, then my client is given notice in e-mail.

Dec 5, 2011 at 2:37 PM

It's working goog in my company :) Only my client not set what I said...

Thank you very much!