Installation

Feb 1, 2012 at 4:07 PM
Edited Feb 2, 2012 at 7:40 PM

Everything actually seems to have installed fine in that I received no errors. It appears in solution manager and in SharePoint Designer BUT there is a caveat though, the item does not show up in my Managed Features under Central Admin. I have also verified that the web.config file is updated with the PublicKeyToken as well. Also, the activities show up in SPD 2010 but when clicked on do not appear in the workflow directly. Do you have any pointers for me to get this running?

Greg

Coordinator
Feb 3, 2012 at 1:40 PM

It will now show up at the farm level, only the web application level for activation in central admin.  What commands did you use to install and activate the feature?

Feb 3, 2012 at 2:17 PM

I used the powershell commandlets exactly as described in the documentation. I then when directly to Central Admin, Application Management, Manage Web Applications, and select each of my web apps and click on Manage features. There is no entry for activities. I also checked the farm level Features and ther eis no entry there. I did run Get-SPSolutions and it does appear in the list as Deployed. Very strange indeed. I have attempted this twice so far.

Feb 3, 2012 at 2:23 PM

As a side note, I just tried installing a different package from codeplex for a different workflow utility and it installed just fine. It was the I love sharepoint utilities. Installed exactly the same way and it appeared in the Manage Features of the Applications. Don't know if that helps or not.

Coordinator
Feb 6, 2012 at 3:17 PM

Greg,

Interesting.   Since i cant duplicate, I'm not sure i can be of much assistance.  Are you running foundation or server?  Do you have SP1 deployed?  Hopefully someone else will stumble across this thread and shed some light on the problem if nothing stands out to you.  If you do figure out what the issue is, please share it so that i can update accordingly.

Thanks,
-Rob

Feb 6, 2012 at 3:59 PM

Our installation is SP1 with all patches to date. We have only been active on 2010 since Novemeber and this is the first 3rd party tool not to install thouroughly. The only thing that I can think of that might be unexpected for you is the fact we are a load balanced frontend. But I was surprised that it didn't install. This is also a server installation.

To verify everyone understands - the add in installed correctly as far as the powershell commands. The solution manager sees the product as installed and the SharePoint Designer sees it as installed. The web.config files are also correctly edited by the installation. The only thing is that the action items, when selected, will not insert into the workflow.

Feb 6, 2012 at 7:12 PM

Hi Greg,

I had 'similar' issues with my installation - it didn't function.  I removed the solution, went through it and did it a second time, and that 'took' (very strange).  In regards to it not appearing in Managed Features - is very strange.  I wonder if it's possible you may have overlooked it...?  When I look at my "Manage Web Application Features" for the single Web App that I deployed this to, It appears with the name, "Custom Workflow Activities".

If after looking at the manage web application features and you're sure it's not there, remove the solution entirely, delete it, and go back through his instructions and redeploy it.  

The fact your servers are LB won't make any difference, it's deploying to all servers during the deployment phase.  You will be able to tell what servers it deployed to by going to Cent Admin -> System -> Manage Farm Solutions -> Click on Customworkflowactiviesproject  -- Look at the "Last Operation Details" and it will list the servers it was successfully deployed.

I hope this helps...

Larry 

Feb 6, 2012 at 7:36 PM

Larry,

Thanks very much for your suggestions. Unfortunately I have retried this twice so far using powershell exactly as noted in docs. In fact I did a double take and nade sure the name was not in the Managed features. I am actually going to try one more time using stsadm commands and see if that makes a difference. It is a shame though because to date I have installed roughly 8 different solutions and have not seen this pop up. I will return in a day or so and let you know what happened. Do have another question about the install though...I would have thought that if I selected GAC deployment that I would see a globaally deployed comment under managed features? Instead, as mentioned above, I see it deployed to all my web apps on each of the LB frontends. Just wondering about that. See you in a day or so!

Greg

Feb 23, 2012 at 1:26 PM

Larry,

 

That worked. It appeared after my third attempt. I also verified on another Web App that I had not placed the authorizationType key in the web.config file. All is well and I appreciate the efforts of all involved!

 

Thanks.